Protocollo sicuro TLS - Comunicazione

Intervento di sicurezza sul protocollo TLS utilizzato dai browser

Come noto il servizio di conservazione deve garantire, per la protezione dei dati conservati, livelli elevati di sicurezza. Nell'ambito dell'attività di costante aggiornamento del servizio, è emerso che alcuni clienti fanno ancora uso di protocolli di comunicazione cifrata vulnerabili. Per questa ragione Unimatica intende disabilitare la possibilità di far uso di tali protocolli, come da linee guida AGID.

Ci si riferisce in particolare alle versione 1.0 e 1.1 del protocollo TLS. Come comunicato, tali protocolli saranno disattivati a far data dal 01/01/2020 a favore delle versioni più recenti 1.2 o superiore.

Come accertarmi che il sistema operativo ed il browser che utilizzo siano compatibili con i protocolli più recenti

Accedendo a questa pagina si otterrà l'indicazione della compatibilità o meno del browser:

​https://quickstream.westpac.com.au/quickportal/BrowserTlsVersionView

Il browser è compatibile

Se il browser supporta TLSv1.2, il cliente visualizzerà il seguente messaggio:

Your browser supports the latest encryption standards.

Il browser non è compatibile

Se il browser non supporta TLSv1.2, il cliente visualizzerà la seguente pagina, nella quale TLS 1.0 e TLS 1.1 saranno disabilitati.

Your browser need to be updated to support the latest encryption standards. Your browser must support the encryption standard known as "TLS 1.2"

 

Nel caso in cui la verifica dia esito negativo

Nel caso in cui la verifica dia esito negativo, è possibile verificare se sia necessario un aggiornamento del sistema operativo, oppure un aggiornamento del browser oppure il passaggio ad altro browser.

Verifica del sistema operativo

​http://whatsmyos.com/

Richiamando l'indirizzo sopra riportato è possibile determinare sistema operativo e versione attualmente in uso.

Di seguito si riporta una tabella con l'elenco dei principali sistemi operativi e relative versioni che non supportano il protocollo sicuro TLS 1.2 e richiedono quindi un aggiornamento di sistema operativo.

Sistema operativo

Versione

Linee guida per il cliente

Mac

Mac OS X 10.9 e inferiori

Il tuo sistema operativo non è supportato da TLS 1.2 e deve essere aggiornato a Mac OS X 10.10 o superiore.Se l'aggiornamento del sistema operativo non è possibile, va cambiato il dispositivo.

Windows

  • Windows 3.1
  • Windows XP
  • Windows 95
  • Windows NT
  • Windows_Vista

Il tuo sistema operativo non è supportato da TLS 1.2 e deve essere aggiornato a Windows 7 o superiore.Se l'aggiornamento del sistema operativo non è possibile, va cambiato il dispositivo.

     

iOS

inferiore a iOS 7

Il tuo sistema operativo non è supportato da TLS 1.2 e deve essere aggiornato.Se l'aggiornamento del sistema operativo non è possibile, va cambiato il dispositivo.

     

Android

Android 4.4 e inferiori

Il tuo sistema operativo non è supportato da TLS 1.2 e deve essere aggiornato alla versione 5 o superiori.Se l'aggiornamento del sistema operativo non è possibile, va cambiato il dispositivo.

 

Verifica del browser

https://www.whatismybrowser.com/

Richiamando l'indirizzo sopra riportato è possibile determinare browser e versione attualmente in uso.

Di seguito si riporta l'elenco dei principali browser e relative versioni che supportano il protocollo sicuro TLS 1.2.

Google Chrome

Versione browser

Sistema operativo

Indicazioni

da v.1 al v.29

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android
  • iOS 9 e superiori
  • Chrome OS

Il browser non supporta TLS 1.2 e deve essere aggiornato.

     

v.30 e superiori

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android
  • iOS 9 e superiori
  • Chrome OS

Il browser supporta TLS 1.2

Browser di Google Android OS

Versione browser

Sistema operativo

Indicazioni

da v.1 a v.4.0.4

Android

Il browser non supporta TLS 1.2 e deve essere aggiornato.

da v.4.1 a v.4.4.4

Android

Deve essere abilitato il supporto di TLS 1.2 nella configurazione del browser.

v.5 e superiori

Android

Il browser supporta TLS 1.2.

Mozilla Firefox

Versione browser

Sistema operativo

Indicazioni

da v.1 a v.23

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android 4.0.3 e superiori
  • iOS 9.0 e superiori

Il browser non supporta TLS 1.2 e deve essere aggiornato.

da v.24 a v.26

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android 4.0.3 e superiori
  • iOS 9.0 e superiori

Deve essere abilitato il supporto di TLS 1.2 nella configurazione del browser.

v.27 e superiori

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android 4.0.3 e superiori
  • iOS 9.0 e superiori

Il browser supporta TLS 1.2.

Microsoft Internet Explorer

Versione browser

Sistema operativo

Indicazioni

IE 8

  • Windows XP
  • Windows Server 2003
  • Windows Server 2008
  • Windows Vista

Il browser non supporta TLS 1.2 e deve essere aggiornato.

 
  • Windows 7
  • Windows Server 2008 R2

Deve essere abilitato il supporto di TLS 1.2 nella configurazione del browser.

IE 9

  • Windows Vista
  • Windows Server 2008

Il browser non supporta TLS 1.2 e deve essere aggiornato.

 
  • Windows 7
  • Windows Server 2008 R2

Deve essere abilitato il supporto di TLS 1.2 nella configurazione del browser.

IE 10

  • Windows 7
  • Windows 8
  • Windows Server 2008 R2
  • Windows Server 2012

Deve essere abilitato il supporto di TLS 1.2 nella configurazione del browser.

IE 11

  • Windows 7
  • Windows 8.1
  • Windows Server 2008 R2
  • Windows Server 2012 R2

Il browser supporta TLS 1.2.

Microsoft Internet Explorer per mobile

Versione browser

Sistema operativo

Indicazioni

v7 e v9

  • Windows Phone 7
  • Windows Phone 7.5
  • Windows Phone 7.8

Il browser non supporta TLS 1.2 e deve essere aggiornato.

v10

  • Windows Phone 8

Deve essere abilitato il supporto di TLS 1.2 nella configurazione del browser.

v11

  • Windows Phone 8.1

Il browser supporta TLS 1.2.

Microsoft Edge

Versione browser

Sistema operativo

Indicazioni

tutte le versioni

Windows 10

Il browser supporta TLS 1.2.

Opera

Versione browser

Sistema operativo

Indicazioni

da v.1 a v.9

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android 4.0 e superiori

Il browser non supporta TLS 1.2 e deve essere aggiornato.

da v.10 a v.12.17

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android 4.0 e superiori

Deve essere abilitato il supporto di TLS 1.2 nella configurazione del browser.

v.12.18

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android 4.0 e superiori

Il browser supporta TLS 1.2.

da v.14 a v.16

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android 4.0 e superiori

Il browser non supporta TLS 1.2 e deve essere aggiornato.

v.17 e superiori

  • Windows 7 e superiori
  • Mac OS X 10.9 e superiori
  • Linux
  • Android 4.0 e superiori

Il browser supporta TLS 1.2.

Apple Safari

Versione browser

Sistema operativo

Indicazioni

da v.1 a v.6

  • Mac OS X
  • IOS 1 e successivi
  • Windows XP

Il browser non supporta TLS 1.2 e deve essere aggiornato.

v.7 e superiori

  • Mac OS X 10.9, 10.10, 10.11, 10.12, 10.1
  • iOS 1.0 e superiori

Il browser supporta TLS 1.2.

Apple Safari per mobile

Versione browser

Sistema operativo

Indicazioni

da v.3 a v.5

  • IOS 1, IOS 2, IOS 3

Il browser non supporta TLS 1.2 e deve essere aggiornato.

v.5 e superiori

  • IOS 5, IOS 6, IOS 7, IOS 8, IOS 9, IOS 10, IOS 11

Il browser supporta TLS 1.2.